Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help For Easy-PC Users
 PCB Layout
 Block solder paste from copper areas
Author Previous Topic Topic Next Topic  

rbuck

USA
57 Posts

Posted - 17 Apr 2016 :  22:07:50  Show Profile  Reply with Quote
I have created two library parts that have copper pour areas in them. The pour areas are not pads, just copper. I need to prevent solder paste from being applied to those areas.
I created a separate solder mask layer to prevent solder mask from being applied to the pads. I was able to figure out how to do that.
I also created a separate solder paste layer. But I can't figure out how to block the paste from those pads. I read a couple of posts about pad exceptions but I don't think that applies since these pour areas are not pads.
Any help would be appreciated.

Iain Wilkie

United Kingdom
960 Posts

Posted - 18 Apr 2016 :  10:40:19  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
Just apply an exception to the pads on the paste layer. Set the paste size to zero.

Iain
Go to Top of Page

rbuck

USA
57 Posts

Posted - 18 Apr 2016 :  16:03:41  Show Profile  Reply with Quote
Thank you Iain. That worked. Your suggestion to set the paste size to zero was the key. I was looking for an option "no paste" but obviously that doesn't exist.

Thank you.

Ray
Go to Top of Page

Geotech

USA
20 Posts

Posted - 23 Feb 2021 :  01:59:06  Show Profile  Reply with Quote
This is exactly what I want to do as well. I created the solder paste layers and created pad exceptions. It works fine within Easy-PC but the exceptions are ignored when creating Gerbers. That is, the paste is still applied to the pads.

Edit: Using V24.0.3

Edited by - Geotech on 23 Feb 2021 02:01:20
Go to Top of Page

edrees

United Kingdom
664 Posts

Posted - 23 Feb 2021 :  09:50:15  Show Profile  Visit edrees's Homepage  Reply with Quote
Goto Design Tech then Layer Types.

For the Solder Paste row you will see what items are allowed solder paste. There will be at least one item that you should apply "No" to.

This should sort out your problem.
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: