Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help For Easy-PC Users
 PCB Layout
 Incorrect position
Author Previous Topic Topic Next Topic  

AndyB

United Kingdom
198 Posts

Posted - 24 Oct 2018 :  15:27:50  Show Profile  Reply with Quote
On v22 when say selecting a set grid .
If I zoom out and move a component it should jump to the grids position?
Well it only does if i zoom in close to the component.
When zoomed out there is an error.

I dont remember previous versions doing this.

Can anyone confirm thiers is doing the same. Thanks

edrees

United Kingdom
575 Posts

Posted - 24 Oct 2018 :  16:01:02  Show Profile  Visit edrees's Homepage  Reply with Quote
Not really Andy.
However, I have noticed a slight issue when an item is already on say a half grid position and I subsequently change the snap to full grid, it sometimes moves to the next half grid position instead of the full grid position.
Go to Top of Page

AndyB

United Kingdom
198 Posts

Posted - 25 Oct 2018 :  12:14:31  Show Profile  Reply with Quote
It seems to happen with components which are more complicated than a single pad.

Try setting a grid. Zoom out and place the components on a 8mm grid.

Then test the position.

I've found odd positions on the y axis of 0.18mm ? when placing like this.

When zooming in and picking and dropping the component again it places correctly.
Go to Top of Page

edrees

United Kingdom
575 Posts

Posted - 25 Oct 2018 :  12:29:38  Show Profile  Visit edrees's Homepage  Reply with Quote
Just tried what you suggested with a 3 way "Molex" style connector on a 8mm grid. Everything seems fine to me, - snaps exactly to grid regardless of zoom level.
Go to Top of Page

AndyB

United Kingdom
198 Posts

Posted - 28 Oct 2018 :  09:24:22  Show Profile  Reply with Quote
why is it doing it to me?
I've been caught out once with this and now have to check every drop i make.
Go to Top of Page

Iain Wilkie

United Kingdom
897 Posts

Posted - 28 Oct 2018 :  15:28:41  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
Does it still alter if you "fix" the component after placement ?

Iain
Go to Top of Page

AndyB

United Kingdom
198 Posts

Posted - 30 Oct 2018 :  18:38:59  Show Profile  Reply with Quote
Iain it's not doing it when I have a simple design.
If I have a mixture of DFX imported layers and a reasonable number of components it seems to have a problem.
It's intermittent in doing so.

Do you have an issue when zooming in with the grid on?
EasyPC chugs to a stop and I have to switch off grid dots.
Maybe it's a memory problem.
I will try upping the ram.


Go to Top of Page

Iain Wilkie

United Kingdom
897 Posts

Posted - 30 Oct 2018 :  19:50:56  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
Hi Andy,

I have to say what you describe I have never had an issue with. There was an issue once with slow re-draw time that made the thing a bit clunky, but that was to do with the net names being shown on the pins (and the tracks perhaps) but that too seems to not be an issue now.

Cheers

Iain
Go to Top of Page

AndyB

United Kingdom
198 Posts

Posted - 20 Nov 2018 :  15:38:00  Show Profile  Reply with Quote
Had a chat with Peter and it's a known issue and has been in easy PC from day one.
Apparently it's a Windows issue as easy PC takes info from windows for positioning?
He said he would post on the thread but must have forgot.
I suggest you all check when placing items in a zoom out situation.
Go to Top of Page

Peter Johnson

United Kingdom
432 Posts

Posted - 28 Nov 2018 :  10:14:44  Show Profile  Visit Peter Johnson's Homepage  Reply with Quote
That's not quite what I said. When you're zoomed out a long way, you tend to get an incorrect reading of the position as Windows reports the co-ordinate of the centre of the pixel back to the program, not the actual symbol/pad origin, so in the status bar co-ordinates you can get a rounding error, which obviously reduces dramatically as you zoom in. I'm not sure when the co-ordinates are taken from a Windows report of the mouse cursor position, and when they're taken directly from the selected item. One of the development team would have to answer this.

Regarding the failure to snap to grid, we've tried to reproduce this, but, like Iain, met with a total lack of success. It must be something local to the machine, but at present it's not clear just what.
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: