Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help For Easy-PC Users
 Manufacturing Outputs
 Bitmap inversion in pdf?
Author Previous Topic Topic Next Topic  

PeteJG

United Kingdom
51 Posts

Posted - 22 Aug 2019 :  09:34:56  Show Profile  Reply with Quote
I "add"ed a bitmap (of the pinout of a BC337) to a schematic, since the circuit is going to veroboard not a PCB. This went fine, and prints ok, but when I try to export the sch as a pdf, the bitmap comes out inverted. Can anyone shed any light on why this might be happening, and what (if anything) can be done to correct it? Thanks.

edrees

United Kingdom
664 Posts

Posted - 22 Aug 2019 :  09:50:23  Show Profile  Visit edrees's Homepage  Reply with Quote
I was playing with Adding Bitmaps yesterday (V23.0 + update) but didn't have the problem you are experiencing. The colours are "reversed" until the image is "dropped" onto the schematic/pcb when it reverts to the correct colour. What I did notice is that the PDF output shows the bitmap in colour regardless of whether to print "All Colours Black" is ticked or not but my (monochrome) laser printer resolves that issue very well.

ADD BITMAP also works with JPG files too.
Go to Top of Page

PeteJG

United Kingdom
51 Posts

Posted - 22 Aug 2019 :  09:57:51  Show Profile  Reply with Quote
Well I'm still on V19 as others here have "migrated" to Pulsonics so my dept won't cough up for an upgrade for me :-(
I have used/struggled with/cursed Pulsonix btw - I'm sure it's manor from heaven for some but for me it's just got far too many settings to mess up and far more bells & whistles than I need!
Go to Top of Page

PeteJG

United Kingdom
51 Posts

Posted - 30 Aug 2019 :  11:51:19  Show Profile  Reply with Quote
Sorry, when I said "inverted" I meant "upside down", in case that makes more sense for an explanation or fix?
Go to Top of Page

edrees

United Kingdom
664 Posts

Posted - 30 Aug 2019 :  12:18:47  Show Profile  Visit edrees's Homepage  Reply with Quote
Sorry for confusion caused, -my imported bitmaps (& JPGs) are the correct way up! (V23.0 + patch).
Go to Top of Page

PeteJG

United Kingdom
51 Posts

Posted - 30 Aug 2019 :  16:46:25  Show Profile  Reply with Quote
Even if you export the sheet to pdf? My bitmaps are fine any other time, including printing (via both routes) onto paper. It ONLY happens when exporting the whole sheet to pdf with this bitmap on it?! I had to do a workaround with a screen cap of the bitmap and bring it in as a jpg instead, then export the sheet, to make it work??

It's ok, I'm guessing this will remain another "feature" to add to the "don't do this that way" section in my notes ....
Go to Top of Page

edrees

United Kingdom
664 Posts

Posted - 30 Aug 2019 :  17:08:09  Show Profile  Visit edrees's Homepage  Reply with Quote
Nope, sorry Peter, all OK here with PDF printing (i.e. exporting to PDF) of JPGs and Bitmaps in Schematic Editor.

As a possible suggestion, check "Preferences" =>"Interactions" and (bottom left hand corner) make sure that Reverse Rotation (Clipboard) and Reverse Rotation (File) are unticked?????

Edited by - edrees on 30 Aug 2019 17:11:44
Go to Top of Page

PeteJG

United Kingdom
51 Posts

Posted - 30 Aug 2019 :  17:23:50  Show Profile  Reply with Quote
Sadly both unticked already :-(

Oh well it is weekend time so I'll leave it for now. Have a good one everyone :-)
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: