Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Help For Easy-PC Users
 PCB Layout
 Silk Screen Problem
Author Previous Topic Topic Next Topic  

Iain Wilkie

United Kingdom
960 Posts

Posted - 26 May 2009 :  11:26:57  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
I have a design were I have put the PCB reference information on the silk screen in text and then next to it a filled shape rectangle where some number info could be hand written by the end user. In the layout editor everything looks ok, but the on the silk screen gerber the rectangle has "moved" and now covers the last two letters on the text !!

Bit worrying this as you expect the layout editor to be WYSIWYG

Iain

Peter Johnson

United Kingdom
459 Posts

Posted - 26 May 2009 :  12:58:48  Show Profile  Visit Peter Johnson's Homepage  Reply with Quote
Would this be a True Type font, or the system stroke font?

If it's True Type, some of the font handling is done by Windows, and there's a known positional bug in it. I'd need a lot more detailed information before I could determine if it's Windows or Easy-PC causing the problem.
Go to Top of Page

Iain Wilkie

United Kingdom
960 Posts

Posted - 26 May 2009 :  13:03:24  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
Peter,

It is a True Type Font (Arial Bold) size about 200 thou

Iain
Go to Top of Page

Iain Wilkie

United Kingdom
960 Posts

Posted - 11 Aug 2020 :  10:35:36  Show Profile  Visit Iain Wilkie's Homepage  Reply with Quote
Just hit on this particular problem again. Been in touch with Peter at Numberone to find out these is a way of getting round this .... and there is a solution !!

If you go to Preferencies/Display and incheck the "Detailed True Type Text " box this will then show this text in the same way as it will on the gerber output, so you can overcome any positional problems with it.

Iain

Go to Top of Page

Peter Johnson

United Kingdom
459 Posts

Posted - 11 Aug 2020 :  15:27:46  Show Profile  Visit Peter Johnson's Homepage  Reply with Quote
There's a long standing bug in the way Windows handles True Type fonts which makes the size dependent upon zoom level. It's demonstrable in other applications besides Easy-PC (including in any text embedded in a Word image!)

The solution (such as it is) is to go to Preferences, Display, and uncheck the box for Detailed Text. That will render the true type text on-screen using the shapes for the glyphs in the same way as plotting. Iain will then see where his '5' is overlapped by the shape. Any adjustment to clear it away on-screen will then be reflected in what comes out in the plot. It's unfortunate that asking True Type fonts to display in higher resolution just exacerbates the problem.
Go to Top of Page
  Previous Topic Topic Next Topic  
Jump To: